Mostrar Mensajes

Esta sección te permite ver todos los posts escritos por este usuario. Ten en cuenta que sólo puedes ver los posts escritos en zonas a las que tienes acceso en este momento.


Mensajes - Naibor

Páginas: [1] 2 3 ... 12
1
He comprado esta CIA en ebay a ChipGate, no sé si son fiables o son un chip fake, pero por el precio que tienen creo que merece la pena probar, y dice que son nuevas sin estrenar.

https://www.ebay.es/itm/152943486286?_trksid=p2380057.m570.l6004&_trkparms=gh1g%3DI152943486286.N41.S1.R1.TR1

Alguien tiene referencias de este vendedor? las opiniones de ebay son muy buenas.

Yo he comprado varias y funcionaban todas, lo que he visto es que ya ha subido el precio  >:( >:(
Los siguientes usuarios dieron las gracias a este tema: Naibor

2
Antes de enchufarla al C64 y jugártela prueba a medir la resistencia entre VCC (con borne rojo) y cada una de las patas de PORTA y PORTB (borne negro) con un tester vulgaris. Una CIA real debe dar una resistencia aproximadamente igual en todos (no recuerdo cuánto, pero entre 1K y 5K). Mi experiencia China con las CIAs fue fake total, pero al menos me devolvieron el dinero.
Los siguientes usuarios dieron las gracias a este tema: Naibor

3
A mi la tipografia no me parece la original, caracteres demasiado estrechos. Yo diria que es un fake. Realmente cualquier chip MOS que venga de China es un fake en un 99%

Ya nos contaras cuando te llegue.
Los siguientes usuarios dieron las gracias a este tema: Naibor

4
Pon la CIA "buena" en U1 y la "mala" en U2.

Si el cursor parpadea, te va el teclado entero y los joys (usa CIADiag o cualquier test de joysticks), entonces el chip va bien 99% seguro porque con eso estás probando toda la funcionalidad del chip.

Los dos 6526 son idénticos, solo hacen funciones distintas según estén en U1 o U2. Si el chip va bien en U1, también debería ir bien en U2.

Prueba también a poner el chip "malo" en U1 y, con el C64 apagado, comprueba la continuidad entre las patas del CHIP y las del ZÓCALO (por el otro lado de la placa) para ver si hacen mal contacto. Si es un tester medianamente decente tendrá un modo "continuidad" que pita cuando juntas los dos cables y no tendrás que andar mirando.

He quitado las 2 CIAs y los juegos en cartucho cargan pero veo basura en pantalla en algunos CRT, por ejemplo Clows se ve bien, pero la gran mayoría de CRT cargan, se escuchan, pero con basura en pantalla.

Esto es normal: el VIC solo puede ver 1 bloque de 16K de memoria la vez. Es la CIA2 la que conmuta entre los 4 "bloques" de 16KB para que el VIC pueda ver toda la memoria. Si algún juego intenta cambiar de bloque y tu CIA2 está kaputt, en la pantalla se verá basura.
Los siguientes usuarios dieron las gracias a este tema: Naibor

5
He debido de cargarme una CIA, porque en un principio arrancaba, pero no parpadeaba el cursor y estaba completamente bloqueado, sin teclado.

...

Ahora arranca y parpadea. Tengo teclado y funcionan los 2 joys.

Hay una cosa que no entiendo aquí: ¿dices que el mismo chip, después de quitarlo y ponerlo dos veces en U1, la primera vez no había cursor, y la segunda sí? Porque entonces el chip estaría bien y tendrías que buscar el problema en la holgura de los zócalos como comentaba marcos64.
Los siguientes usuarios dieron las gracias a este tema: Naibor

6
Espera unos dias por si el limpiador ha entrado en algun sitio que no deberia. Si es asi se evaporara. Poco probable pero merece la pena probar.

Examina los zocalos por si hay alguna holgura o oxido o algun pequeno objeto (pelusa o pequeña basura en general). De nuevo, poco probable, pero a veces al limpiar se puede haber incrustado algo pequeño.

Intercambia las CIAs y los sintomas deberian variar: fallo de teclado y joystick una y fallo de la unidad de discos por otra.
Los siguientes usuarios dieron las gracias a este tema: Naibor

7
Ouch, qué putada!

La CIA U1 controla teclado, joysticks y cursor. La U2 el cassette, la diskettera y el puerto usuario. Con eso puedes diagnosticarlas. Por suerte aún son baratas en retroleum. A ver si tienes suerte y es mal contacto con el zócalo.

Son muy sensibles a las descargas electrostáticas, la protección que llevaban contra ellas es nula o muy inefectiva.
Los siguientes usuarios dieron las gracias a este tema: Naibor

8
El problema del 'se desconectan' es que efectivamente no se destruyen pero por ejemplo puede dejar loco al VIC porque le sigan llegando los 5 y no los 12 o viceversa. Cuando se enfrían vuelven a ir hasta que se calientan lo que puede generar un vaivén que te vuelva loco o acabé rompiendo algo.

Hay equivalentes pin a pin conmutados que no se calientan, pero no sé si meterían ruido eléctrico. Habría que probar.
Muchos usuarios de spectrum Cambian el 7805 por uno conmutado y les va bien.
Los siguientes usuarios dieron las gracias a este tema: Naibor

9
Esos 20V son un poco bestias, debería ser algo más entre 14 y 16V. No es grave porque el máximo del 7805 y 7812 es bastante superior: unos 35V que varían según fabricante, pero tienes que tener en cuenta que los reguladores lineales como el 7805 y el 7812 funcionan convirtiendo el exceso de voltaje en calor. Por ejemplo, si el 7805 tiene que bajar esos 20V a 5V y por él circulan, p.ej. 0.2A (no sé cuánto circula por el 7805 interno del C64, así que lo digo a ojo), el exceso de voltaje es 15V y la potencia disipada será 15 * 0.2 (corriente * voltaje) = 3 W. Eso significa que tu 7805, aparte de cumplir su función reguladora de voltaje, se comporta como una pequeña estufita de 3 watios, que no parece mucho pero para un encapsulado tan pequeño sí que lo es. Tócalo a ver si quema mucho, aunque el 7805 puede aguantar temperaturas superiores a los 70º y la prueba de quemarse con el dedo tampoco es muy significativa.

De todas formas tampoco hay que ser fanático con la temperatura del 7812/05 porque en teoría tienen protección contra sobrecalentamiento (se desconectan), siempre y cuando sean de un fabricante con reputación, porque parece ser que hasta de los 78xx hay clones low cost.
Los siguientes usuarios dieron las gracias a este tema: Naibor

10
Los 20V a la entrada del 7812 son algo elevados pero creo recordar que normales, al menos en mi 1541 tambien estaba por ahi.

De todas formas, para completar, comprueba tambien los 9Vca en el puerto del usuario.
Los siguientes usuarios dieron las gracias a este tema: Naibor

11
El 7805 mide 4,94v estables
Pero el 7812 mide En la patilla 1 casi 20v !!! 19,8 ¿ ¡¡ Esto es correcto !! ?
En la patilla 3 11,98V
Lo importante es la salida. Por una parte te dan casi 5v y el otro casi 12v. Estan bien.
Los siguientes usuarios dieron las gracias a este tema: Naibor

12
Me picó la curiosidad y he comprobado el voltaje de salida de un 7805 desmontado hace poquito del C64 y los resultados son:
Para una fuente de entrada de 8'33v en cc me ha dado una salida de 5'02v cc bastante aceptable. El regulador estaba bien... pero no me la juego y lo cambié.
Los siguientes usuarios dieron las gracias a este tema: Naibor

13
Y de las tres patas que tiene, cuáles debo de medir?
Cada regulador vale 50 centimos de euro... no vale la pena y por la edad que tienen, cambialos. Recuerda de poner un poco de pasta térmica en el de 5v, el del difusor.
De todas formas la pata izq es entrada de voltaje, la central GND y la derecha es la salida. Puedes comprobar con una fuente de alimentacion conectada a pata izq positivo, central neutra y el tester en pata central neutro y pata derecha positivo. Eso sí, la corriente de entrada un poco superior a 5v en continuo, unos 2v por encima. Si está bien te deberian dar los 5v de cc en salida. Pero ya te digo que por el precio no vale la pena y es mas seguro cambiarlos.
Los siguientes usuarios dieron las gracias a este tema: Naibor

14
Por cierto, ¿qué es el 7805?
Como dice @marcos64 , el 7805 es un integrado que el voltaje de salida será siempre de 5v constante y estable.
En la placa del C64 encontrarás un 7812 y un 7805. Cada uno dará su correspondiente voltaje estable segun sus 2 últimas cifras.
Te pongo una foto de los mismos antes de ser substituidos por unos nuevos.
A la izquierda el 7812 y a la derecha el 7805.
Los siguientes usuarios dieron las gracias a este tema: Naibor

15
Perdona marcos64 no había entendido tu mensaje anterior al decir que midiera los 5V en el VIC.

No me había dado cuenta de que el VIC tenía 2 voltajes:

12V en el pin 13
5V en el pin 40

Qué cosas hacían en la época...

Muchas gracias de nuevo marcos64 a ver si saco tiempo y vuelvo a medir voltajes.

Por cierto, ¿qué es el 7805?

El SID tambien tiene los 2 voltajes.

El 7805 es el regulador https://en.wikipedia.org/wiki/78xx que crea los 5Vcc de los 9Vca que da la fuente (junto con otros componentes). Esta abajo a la derecha encima de un disipador de aluminio. Tambien se calienta bastante.
Los siguientes usuarios dieron las gracias a este tema: Naibor

Páginas: [1] 2 3 ... 12